Frequent Visitor
Posts: 3
Registered: ‎07-06-2010

Any Old J.I. Case mechanics ?

I've got an old case 970 that has me really stumped.  While I was chopping haylage, I stopped to change wagons. When I started up again, I engaged the pto clutch, then opened the throttle. The chopper came up to speed, then started coasting back down and came to a full stop, with pto engaged and full throttle. After I determined that the clutch linkage  was all working, I tried again, same result.  About then I also discovered that I seemed to have no hydraulic function at all.( steering, power shift ,3 pt or remotes )  with full throttle. Next I cracked the fittings on the pump and found no output at all.  I then  took out the six bolts and  pulled the pump off. I grabbed the splined shaft in the housing (on tractor,not the pump, which I had laid aside) and turned it by hand.  After dinking around a bit, I could no longer turn it by hand. I then decided that I must have stripped the splines on one of the shafts or couplings inside. I put the pump back on and connected up started the engine and had  normal function of hydraulic system. So I unhooked the chopper and gingerly drove the tractor about 5 miles home. I rented a tractor to finish chopping, and then worked a 4 day swing at the paper mill. When I finally got to it, I drained out the oil and removed  the pto asembly from the rear of tractor. I pulled that long shaft and inspected all the couplings and  looked carefully at the splines on the shaft up in the front.  Found all in perfect shape. While I was in there, I also dismantled and inspected the pto clutch, which I had replaced-rebuilt two or thee years ago and might have 150 hours on it, at the most.  I could not find anything wrong with the clutch either, so put shat back in coupling and tried to turn it  by hand. I could not budge it, so pretty well ruled out a stripped spline in flywheel or transmission shaft. When I put all back together, Hydraulics work fine, pto shaft turn when clutch is engaged, stops when disengaged, but will not even run a forage blower empty or take any load whatsoever Any help, suggestions or ideas are greatly appreciated.  TIA